Vue.js

Vue packages version mismatchエラーの対応

2020/02/08

先日「Vue packages version mismatch」というエラーに遭遇しました。

Vue packages version mismatch:

- vue@2.6.11 (/app/node_modules/vue/dist/vue.runtime.common.js)
- vue-template-compiler@2.6.10 (/app/node_modules/vue-template-compiler/package.json)

This may cause things to work incorrectly. Make sure to use the same version for both.
If you are using vue-loader@>=10.0, simply update vue-template-compiler.
If you are using vue-loader@<10.0 or vueify, re-installing vue-loader/vueify should bump vue-template-compiler to the latest.
  • vue
  • vue-template-compiler

のバージョンが異なっていると起こるらしい。

エラー文で指示されている通り、

yarn upgrade vue-template-compiler

上記を実行してやることで解決しました。(今回の場合だと、vue-template-compiler@2.6.11にバージョンアップ)